Questions & Answers

Updated to UC 3.4.1.63149 and can't update my firmware on my Quantum 2.

0 votes
404 views
asked Feb 20, 2021 in Thunderbolt - Quantum by daveberm (210 points)

After I updated  I got a message to update the firmware on my Quantum 2. I clicked on the link, but nothing is happening. Any ideas?

2 Answers

0 votes
answered Dec 20, 2022 by gaihetyu (200 points)
edited Dec 20, 2022 by gaihetyu
I have this exact issue with my Presonus Quantum 2626 and support has not helped. I've tried everything and still have the issue. I have 2 of these interfaces, so I am not happy with PreSonus at all. I've basically turned off all security, firewall, etc. purchased new Apple Thunderbolt 3 cables and nothing works. I can't update the device firmware. There's no button like they show in the documentation. I just have this PLEASE UPDATE DEVICE FIRMWARE! text that underlines like a clickable link when you hover the mouse over it, but clicking it does nothing!

I have an iMac Pro with 8 Core Intel Xenon W, 32 GB RAM, running Ventura 13.0.1, but this has been an issue for about 2 years.
0 votes
answered Feb 17, 2023 by gaihetyu (200 points)
I have the same issue with my Quantum 2626s (I have 2). Can't install the firmware for the last 3 firmware releases. There's not button to press. I think it has to do with the iMac Pro. I've tried everything, even getting into Terminal and removing the firewall and anything else that would block the software. Presonus has not been helpful at all on this. Best recommendation is to try doing it on another computer, but I don't have another computer with Thunderbolt 3 and don't know anyone around here that does.
...