Questions & Answers

Studiolive Daw Mode Is Not Working In Pro Tools

+2 votes
asked Mar 13, 2021 in StudioLive Series III by thomaskerr3 (240 points)
I am having a lot of trouble trying to get Daw control on my Studiolive 32sx in pro tools.
I feel like I have tried every piece of advice on your website but still no avail.

I have updated the firmware,
Reinstalled UC surface,
made sure the Network Midi has a green dot beside the studiolive,
checked different ethernet cables,
I am connected to the control and not AVB,
I have firewall turned off and do not own any other VPN, Malware, or other software that uses Ucnet ( unless theres other softwares not listed on your website that use UC net)
I have checked the IP addressing and UC still recognises the mixer when the usb is unplugged,
I have self assign on the ucnet menu on the board.
I am connecting direct from the board to the computer and not through a wireless router.

I have tried to verify the ip address with the connection ping thing on the website but I don't know how to do that even with following the instructions.

I have watched the videos on how to use daw mode in pro tools but after i select Hui in the midi controllers tab, there is "none" when i try to select the send to and recieve from.

I have a 2020 13' mackbook pro, with big sur.

3 Answers

+1 vote
answered Aug 5, 2021 by thomaskerr3 (240 points)
selected Aug 9, 2021 by mackjohnson1
Best answer
I've only recently got it solved. There's a Facebook group where you can download a new beta version of the firmware for the mixer.  The beta version works perfectly for me. It's a private group called "PreSonus StudioLive Series III Public Beta"

Presonus support told me to direct any problems to the group if you have any problems.

I really hope this helps, I've been searching for a solution for 6 months.
+1 vote
answered Aug 5, 2021 by tomrawlings (380 points)
Did you ever get this resolved? I have the same problem and have tried all the same things you listed. Still no DAW mode for Pro Tools. Just wondered if you had figured it out yet.
0 votes
answered Feb 11 by brandonsnow (580 points)
Im using Protools 2022.12 "in rosetta" on a Mac Studio M1 Ultra. Mac OS Monterey and I have found a solid solution!

"V Control Pro" you can check it out here

This is an app that allows legacy equipment to work, via HUI, with any current release of ProTools. For example old C24 type boards, from the Digidesign days, can work with an hdx or carbon on any new Mac,  intel or M1 or M2.

V Control Pro supports the Faderport with a custom map that "supercharges" it for ProTools. I figured the code for that application wouldn't be far off from the SL 32s iii, so I downloaded  the free version to test out. The setup is not straight forward, but it is pretty well explained.

I found that the issue was that protools would receive communication from the SL32siii... BUT the SL32siii  would not receive communication from ProTools, or any other HUI capable DAW or editing app.

V Control acts like an adapter to help ProTools and UC talk.  In the initial setup of V control, just like in UC and ProTools, you have to check all four "banks" UCNET sl32 main and ext 1, ext 2....

In ProTools, in the "Midi Controllers" tab of "Peripherals," setup HUI to receive from ucnetmidiSL32main and ext 1,2,3. Then, setup HUI to send to V-Control and ext 1,2,3.

This has worked for me and I must say, it is even more solid than when I was working on my old Mac Pro using Mojave and Catalina. No warnings that Protools can't communicate with HUI... It just works, solid, every time I boot up. Still no Pan control... but everything else is there.

I am not affiliated with V-control. I simply discovered this and wanted to share. Maybe Presonus can get a copy and see what Neyrink did. This might save someone else the $200 I spent on a perpetual license to V-control Pro.