Questions & Answers

S1 5.2 Mindblowing

+1 vote
86 views
asked Mar 14 in Studio One 5 by fransvannispen (4,760 points)
Another version further, and the keyboard focus issues are still not fixed. It is completely frustrating and irritating to work with Melodyne in S1 for example. Using up/down arrows in Melodyne, which should move notes in Melodyne, switches the active track making Melodyne disappear. Using Undo on a Melodyne note regularly completely removes the Melodyne plugin all together because it does an undo on the track where you just put it on. Things in the arranger window gets undo'd, having no clue anymore what the state of the project is. This is just unworkable. And it is behaving like this ever since Studio One 4. I think this is the 4th time I report this issue.

Another new issue arose with 5.2: Melodyne (not checked other plugins) can no longer be run in a window if you have S1 in full screen. It will only allow you to doc it, have it on a separated fullscreen or puts it on a desktop window and not in S1. (OSX 10.14.5).

And the layer selects are still not respected. Everything in S1 that has multi-select does actions on all of the selected elements, but not the track layers. As a senior developer I cannot get my head around the fact that Persons is just unwilling to flag this as a bug. It does not crash the app, but it does not do what you expect it to do either. Plus it's not in line of the behaviour in the rest of the app. It is just annoying if you had a bad singer in and want to delete 10 takes. Selecting them all and right-click to delete does not delete the selected tracks, only the one on which you right-clicked. Right-clicking on a layer that was not in the selection just removes the selection and selects the layer on which you right-clicked. What is the point in having a multi-select option if it doesn't do anything at all, but confuse the user?

Adding new features is great, and I love a lot of the new functionality. But I'd much more like it if these crucial workflow issues were fixed.

2 Answers

+1 vote
answered Mar 14 by tothrec (20,680 points)
1. Use the Mac version of Ctrl (is it Command) along with up/down to change the pitch.  Normal up/down to go to next/prev note

2. I moved a note up then hit undo.  The note went back down as expected (Melodyne remains)

3. "Melodyne can no longer be run in a window" - I usually put it on a separate screen.  But to try and reproduce the issue you are facing, I put S1 into full screen (Shift F) and tried the various places for Melodyne (docked, undocked).  Could you provide the steps you are taking and how it should look?

4. "Layer selects not respected" - I'm with you on this one (have you submitted a Feature Request?  I'm sure it would get a ton of votes)

Steven
+1 vote
answered Mar 15 by fransvannispen (4,760 points)
@Steven,

1. The keyboard focus issue is not tied to Melodyne. It happend to me with all plugins/ Melodyne just happens to be the one where I use keyboard shortcuts the most.

2. It does not happen all the time, sometimes it works as expected. But it can lose focus while being at work in the Melodyne editor. Maybe it has to do with setting the time slider in the arranger window while working in the Melodyne editor, which I sometimes have to do as the time cursor in Melodyne does not always stay at the position I set it to. Most often it goes back to where it was before.

But it happens to me a lot that the editor window loses keyboard focus. Sometimes it helps to click on the window header bar, but this does not work always either.

3. I put my S1 in fullscreen, then open the Melodyne editor. It opens in a docked window. When I click the undock button it switched to a separate fullscreen window. Then I click on the window button at the right top, and it swicthes to a window on an empty desktop in stead of a window on the S1 fullscreen. I cannot break out of this loop.

4. I have posted several bug reports, and the only response I get I is that it is not a bug, as it has always worked like this (yes true, but that is because it has never worked properly). I also posted a feature request last year.
...