Questions & Answers

Universal Control won't show launcher

+2 votes
asked Oct 1, 2021 in MyPreSonus Questions by rockylowther (1,220 points)
Universal Control won't show launcher anymore. Is it not compatible with Mac mini M1 Big Sur 11.6 ?

Everything in icon on the icon bar is grayed out. I tried it in Rosetta mode too and it's a no go.

I also am using Presonus Sphere, could that be it?

Am I missing something here?

Thanks for any help.

2 Answers

+1 vote
answered Oct 2, 2021 by jaskamalsinghbalam (300 points)
Same issue here, I am using macOS Catalina 10.15.7, iMac 27" 2012.

No audio through Studio Live 32 both Youtube and SO 5.4.

UC does not open at all and no window appear even clicking it.

No one answer and solve the issue, but debiting my money for Sphere membership.
+1 vote
answered Oct 5, 2021 by rockylowther (1,220 points)


Went back to UC Version 3.5.2 and it works now in Rosette Mode on my Mac mini M1.

I don't know if it checks hardware or anything but it does come up now.

The latest version UC doesn't work for me in either mode.