Questions & Answers

How do i use ezdrummer in Studio One 3...???

0 votes
4,677 views
asked Jul 31, 2016 in Studio One 3 by mickedge (260 points)
reshown Aug 2, 2016 by mickedge
This might be a simple question, but i cannot for the life of me, figure out how to use ezdrummer in Studio One 3...!! I know this question has been asked before, but it doesn't answer it for me. For example- nope....just tried to cut & paste the answer i saw, have to do it manually....!

1st step, test it as standalone......ok done. Assigning correct audio drivers (done) & midi inputs...??? No MIDI device found...?

I'm stuck..........i cannot find one video that explains how to get it working..?? Oh... plenty of videos, but they generally skip over one vital part that i just dont understand & cant figure out..! Judging by the amount of unanswered questions here, i doubt this will be answered.......

Can someone point me in the right direction please...

2 Answers

0 votes
answered Aug 2, 2016 by heikomlodystach1 (610 points)
edited Aug 2, 2016 by heikomlodystach1

Hi there,

1.) Create a new instrument track by dropping the instrument into the arrangement.

2.) (Optional) Enable separate output channels for each instrument using the instruments-tab in the mixer and in the EZDrummer-Mixer. 

That way, you get separate mixer channels for mixing the individual drums, which is pretty handy.

3.) Assign a midi-input-device and channel.

You must create it in the "external instruments" section of the StudioOne preferences. Just choose the midi-input-port you are using to trigger the drums. In the video I choose my VMK-88-Controller-Keyboard.

4.) Record arm your track and enable monitoring

You should now be able to play EZDrummer using your hardware midi-controller.


https://www.dropbox.com/s/is8mc1nb5xmto6x/ezdrummer.mov?dl=0

0 votes
answered Aug 2, 2016 by mickedge (260 points)
Thanks for the answer....but unfortunately the problem was - i couldn't see or drag ezdrummer anywhere..! Perhaps i didn't ask the right question...being new to this. But actually before you can drag ezdrummer anywhere, Studio One 3 has to know where to look for it....THAT was the issue. I couldn't see ezdrummer anywhere because its location wasn't set. Every description i've seen & tried....did not work because apparently you have to point S1 3 to the folder which contains THE .DLL file....something which i haven't seen in any other description....i dont know why that is...but it worked...
...