Questions & Answers

AudioBox iOne "Please update device firmware!?"

0 votes
1,011 views
asked Oct 10, 2017 in AudioBox USB by mikebarske (210 points)

Hi....

I just updated Universal Control to version 2.3.0.44619 Win x86 (Built on Sep 22 2017).

Now the UC flashes "PLEASE UPDATE DEVICE FIRMWARE!" with a yellow font-color. 

It seems you can click it, but nothing happens when you do? 

Tried find a solution online, tried different things like restarting, unplugging device and such.

I really find Presonus's applications to be very unreliable and hard to make "just work". 

Any suggestions? 

- Mike

4 Answers

0 votes
answered Oct 10, 2017 by donaldbaarns (9,720 points)

It's on the menu system.

Try "Settings > Update Firmware" and it's easy.


Tip: It's always a win to explore the menu system on every app you use, to get a feel for additional options.

PreSonus is extremely pro active in terms of keeping their stuff up-to-date, so it works across a wide range of configurations, and has the fewest issues possible.

Both Windows and Mac are constantly updating, and PreSonus does an excellent job keeping up. I don't know of any other hardware/software firm doing it better, they are among the best.
 

0 votes
answered Oct 10, 2017 by mikebarske (210 points)

Hi again! 

Thanks for the quick response... but...

Problem is that it is greyed out, look here:

0 votes
answered Oct 10, 2017 by donaldbaarns (9,720 points)
I'd verify that you have the latest Universal Controller installed first.

I'm assuming you downloaded the latest rather than using a CD that is with the interface.

As of this writing the latest is 2.3.0.x

That said, on the File menu is a "Check for Updates".

I'd use that to verify the UC is up to date first.

I hope that helps.
asked Jan 30, 2018 in AudioBox USB by paulblunden (120 points) How do I update the firmware?
0 votes
answered May 23 by georgealexander (140 points)
Has this been answered?  I have the same problem - Universal Controller asking to "PLEASE UPDATE DEVICE FIRMWARE" but that menu "Settings/Firmware Update..." is greyed out and unavailable.

Meanwhile I'm getting Window messages saying Limited or No Connectivity to Audiobox.

OS Name Microsoft Windows 10 Enterprise

Version 10.0.17763 Build 17763

System Manufacturer LENOVO

System Model 20KGS8GB10

System Type x64-based PC

System SKU LENOVO_MT_20KG_BU_Think_FM_ThinkPad X1 Carbon 6th

Processor Intel(R) Core(TM) i7-8650U CPU @ 1.90GHz, 2112 Mhz, 4 Core(s), 8 Logical Processor(s)

BIOS Version/Date LENOVO N23ET56W (1.31 ), 9/17/2018
...