Questions & Answers

Can not update Faderport firmware to 1.45 via latest UC.

+23 votes
asked Jul 11, 2018 in FaderPort Classic by (730 points)
I unplug USB connection : hold down REW,STOP and Record buttons : plug in USB and press OK on computer : get error code nr 0x8004005.

tried 2 diffrent mac with latest OS : same on both computers. cheers M

55 Answers

+1 vote
answered Jul 13, 2018 by (730 points)
selected Dec 4, 2018 by nickmaggio
Best answer

I got this answer from Presonus Tech Support :

" Technical SupportYesterday at 19:58

Hello Magnus,

Thank you for your continued patience as we work to assist you.

Please understand that the FaderPort classic cannot be updated on a USB 3.0 connection.

You will need to connect and update your FaderPort on a computer that has USB 2.0 connections.

You have some viable options.

- Find any other computer with USB 2.0 connection and update.


- Use a commonly available powered USB 2.0 hub.  Connect the FaderPort to this and update."

So I have to find some old USB 2 hub or Mac. I have tried to connect vis keyboard USB (2.0) but same error code.....

My Faderport Classic works fine with FW 1.0 so far....

/cheers M

+6 votes
answered Jul 11, 2018 by gavinsteiner (1,230 points)
Just to let you know I'm facing the same issue. Windows 10 64bit.
0 votes
answered Jul 11, 2018 by Ninosachii (140 points)
do you have the faderport classic or the latest one.?? because i'm facing the same issue with my faderport classic
+2 votes
answered Jul 11, 2018 by (730 points)
Its Classic faderport and shows up in latesr UC device list.
+4 votes
answered Jul 12, 2018 by simonscholefield (300 points)

Yes I am getting the same error msg.  Have followed the instructions and tried everything I can think of or have read on forums etc but still get the 0x8004005 error msg.  The current firmware is reading as 1.0 and am attempting to update to 1.45.

Is the Faderport Classic on Windows 10 64bit

+1 vote
answered Jul 12, 2018 by fwubidzk (220 points)
I have the same problem on Windows10 x64.

So I 'm still usuing v1.0.
+4 votes
answered Jul 12, 2018 by emilteiger1 (390 points)
Same here with Faderport classic on osx (tried on several machines).
0 votes
answered Jul 12, 2018 by pierregauthier (460 points)
Same problem on my side.
+3 votes
answered Jul 12, 2018 by sithlrd73 (200 points)
Same here and now it wont work at all
+3 votes
answered Jul 12, 2018 by rainerpandolfi (210 points)

same error code here  .... Mac HighSierra with Faderport classic ... but not only not to upgrate the Firmware....  also the Faderport do not work anymore .... the old firmware is goen too

+3 votes
answered Jul 13, 2018 by tomtarai (280 points)
I have the same problem here on Windows10 x64. Presonus pls. fix this! Thanx
0 votes
answered Jul 13, 2018 by (730 points)
So I connected via an old USB 2.o hub and voila : sucess : finally upgraded FW to 1.45. So try to use a USB 2.0 native usb or a USB 2.0 hub : that will probably do the trick .

/thanks for all answers and cheers M
+2 votes
answered Jul 14, 2018 by michaelmockley (360 points)
Still not working, USB 2.0 right off the motherboard. unplugged everything except keyboard & mouse. running windows 10 (1803) unfortunately its still buggy.  v1.0 still works.
+2 votes
answered Jul 14, 2018 by simonscholefield (300 points)
yeah I tried through usb 2.0 hub, still getting the same error msg.  Windows 10 64bit.  Will keep going with firmware 1.0.
+2 votes
answered Jul 16, 2018 by (730 points)
Okay so its seems to be a issue with the Faderport Classic firmware update in UC : as I posted before I had success on my Mac OS with an old external USB 2.0 hub : it did the trick for me. But there seems to be problems with Windows 64-bit .I hope Presonus adress this problem in next UC update.....

/cheers M
+1 vote
answered Jul 16, 2018 by alexbyrd (160 points)
I also have the same problem  - win 10 64 bit  - even tried it on a virtual box running win 7 and forcing both the usb elements of  the faderport to only connect to the virtual machine. tried it on a usb2 hub as well as a usb 2 motherboard connection and it fails the same - still works under version 1 but would be nice to get it upto date.

hope we get an answer~

+1 vote
answered Jul 16, 2018 by davechapman2 (160 points)
edited Jul 17, 2018 by davechapman2
Granted this is a legacy product, but to only make it updatable via a legacy port, really?

-- UPDATE --

Thank you, Magnus, I stand corrected. I'm am glad, however, that I save old tech hardware. Laugh if you must but I still have a 3.25 disk drive and my original DOS 6.1 install disks! (as well as Win3.1, 95, 98, NT Server) Maybe I need therapy!

Flash ran fine on an old Dell Vostro laptop.
+7 votes
answered Jul 17, 2018 by (730 points)
But its not a legacy product : Persons still sells them as "Faderport Classic" in their online shop....

so a firmware update should work on todays computer  .(eg USB 3 ).

/cheers M
+3 votes
answered Jul 18, 2018 by chiilthenkt1 (280 points)
Same problem! On Windows 10 x64, using USB2.0 port on motherboard already, anyone has solutions?
+5 votes
answered Jul 21, 2018 by HitzHits (690 points)
Is this a freaking joke? PreSonus.. hello????? USB 2... I don't have old stuff like that. Got ride of it years ago. I updated everything to UBS 3.0.

How in the world would you release an update that only works with legacy hardware...

So how can I update without USB 2.0 Hub? Why would I want to buy other stuff from you, if you can't even provide a driver for your hardware...

0 votes
answered Jul 23, 2018 by robertnorberg (1,160 points)
Problem solved for me!

- Mac os Sierra.

I connected the Faderport "classic" to my Apple Keyboard usb 2.

// Robert
0 votes
answered Jul 24, 2018 by pierregauthier (460 points)
Done with an old laptop running Windows 7.
+2 votes
answered Aug 4, 2018 by dmuckala (190 points)
Just to add to what's already been said on this thread...I was unable to update my faderport classic using any of the methods described: usb 2.0 hub attached to my macbook pro 2015 or trashcan didn't work.  Neither did apple classic keyboard usb 2.0.  I almost gave up until I remembered I had an old imac from 2009, so i got it out of the closet, fired it up, booted it off a usb drive that had El Capitan on it, and plugged the faderport into one of its native usb ports in the back which are obviously 2.0.  For some reason, that seemed to do the trick.  Pretty ridiculous that we have to jump through all these hoops to get a working faderport.
+2 votes
answered Sep 3, 2018 by steveroche (180 points)
same issue.  Win 10, tried USB2.0 port as well.  still no fix for this?
0 votes
answered Sep 11, 2018 by pauldecesare (5,560 points)

I posted this same answer to a similar question about FaderPort 8... it's a weird answer but if you are stuck it's something to try: I had that same issue with my FaderPort 8 on the old firmware when it arrived last month, and also two years ago when I plugged in my Studio 192 Mobile with old firmware... in BOTH instances i was using the cheap supplied USB cable from PreSonus. The way I got the 192 to be recognized and connect was using a $40 digital USB cable, the ones that people say are snake oil. In almost 2 years my 192 has NEVER failed to spin right up now on this cable, and it's just on USB 2.0, not even 3.0 which isn't even necessary. Soooo, the FaderPort 8 shows up last month, and guess what... I could get it to connect in Windows 10, but it would hang when trying to actuallyt run it, and it wouldn't show up in UC. Frustrating. So I unplugged the digital cable from the 192 and tried that on the FaderPort 8, and I think you can guess what happened: FaderPort showed right up in UC, and the firmware update went off without a hitch. I now own 3 of these cables, one for the 192, one for FaderPort 8 and one for my M-Audio CODE61 (black) controller. Google how many people struggle with the CODE series keyboards... locking up, needing rebooting. I had the 49 then sold it for the 61, and neither keyboard has locked up, not ONCE, using the digital cables. I know... this is a weird answer, but the $120 I spent on three lousy USB cables has turned my home studio experience into a joy, at least hardware wise. Those cables don't do anything for consumer peripherals, but for a clean path for a ton of data in music production, they work. Funny thing is, the $40 version is the lower end! They make digital USB cables that cost about $80 and $120! The $40 one is perfecto for a digital music studio.

Nothing to lose, Amazon return policy is awesome.

+1 vote
answered Sep 24, 2018 by alexshore (170 points)
Same issue, don't have any access to a USB 2.0 device either.
+1 vote
answered Sep 26, 2018 by ukaszborowiecki (160 points)
I tray 5 diferent usb 2.0 hubs and 8 cables in all usb ports in my mac pro and finaly I get updata.. . ;)
+2 votes
answered Sep 27, 2018 by tapanisiirtola (1,460 points)
Windows 10 64bit, Faderport classic plugged into USB 2.0 on a motherboard and I got the same error. This needs fixing!
+1 vote
answered Oct 5, 2018 by brandonrubacha (160 points)
So, I just finished 3 months of trying to get this to work. I bought mine used from Guitar Center for $40 and it did not include a power supply. The fader would not work (motorized wouldn't work, it worked non motorized). I learned that you must have at least firmware V1.3 or above for the fader to work. So I tried to to update the firmware, same error code nr 0x8004005.

I tried multiple USB hubs, no luck. I tried a different windows 10 computer, no luck. (I ended up getting it updated) but even after getting it updated, fader still did not move automatically when I switched channels. (Also I was originally plugged into a USB 2.0 on my motherboard, so it's not just a USB 3.0 issue, but a driver issue with windows 10, thanks Presonus.)

To update the firmware I went to an old Window 7 laptop and the update worked.

After getting the firmware updated I couldn't get the fader working. Turns out the power supply I was using (I had to use one on hand because Guitar Center didn't send one) was the issue. The power supply fit and provided proper power, but for some reason it did not work. My multieffect board power supply ended up making it work.

Takeaway: Presonus fix the USB 3.0 issue and make it work on USB 3.0. Also fix the overall ability to update firmware on windows 10...
+1 vote
answered Oct 30, 2018 by joegallo1 (160 points)
I'm having the same issue. I got mine through a trade but I am nervous to update the firmware now. I have an old iMac upstairs I can try to update on but once the Firmware is updated do I still have to be dependent on USB 2.0? Or is that only for the firmware update?
+1 vote
answered Oct 30, 2018 by danielbuitron1 (300 points)

I've noticed that everyone seems to be saying doing it on a old (Windows 7 isn't very "old" if you ask me, I still use it) Win 7 machine worked. However I'm running said machine, 64-bit. And still doesn't work. I've tried plugging into the 2.0 ports on my tower, nothing has worked. I tried plugging it into the 2.0 hub built into my desktop monitor, still didn't work. Hell I even tried plugging it into a newer windows 10 laptop with only usb 3.0 ports and that still did not work. I don't know what the issue is here! I bought mine used, but looks like perfectly new condition off of ebay. There really shouldn't be a problem here. Similar problems i've had with my Audiobox 22VSL; as much as I like Presonus products, they've never been so "plug and play" for me in my experience, sadly. I hope someone has a real solution for this. 

+1 vote
answered Oct 31, 2018 by (730 points)
So I guess I was lucky : after updated firmware with an old USB 2.0 hub : I have been using my Faderport Classic now for

some time : using my ordinary USB 3.0 ports on MacPro : no problems . So it seems to be the update process that is the problem

for both Mac an PC.

/cheers Magnus Malmberg
+1 vote
answered Nov 21, 2018 by philangus (9,750 points)
Presonus support, you really need to sort this out as clearly there is an issue. I have tried on my PC and my laptop. My PC has USB2, it does not work. My laptop is USB3 only, so I connected an old USB2 hub and it doesn't work with that either. I also tried the hub on the PC. I am using Windows 10 64 bit as well. I get the pop up, I get the device ready for update etc, I click OK and then after about 5 seconds I get the error. I have spent two hours trying lots of different ports and methods. Nothing works.
+1 vote
answered Nov 24, 2018 by chrislafargue (250 points)
Still not working . PreSounus a solution please!!!
+1 vote
answered Dec 16, 2018 by malinimauro (220 points)
Stesso problema con Faderport Classic su Win 10 64bit , dopo aver eseguito procedura di update restituisce codice errore 0x80004005 .

Prego Presonus di risolvere problema aggiornamento Firmware 1.45 da 1.0 .

Anticipatamente ringrazio.
+1 vote
answered Dec 19, 2018 by samuliraappana (180 points)
Same problem here! Mac OS X Mojave. Tried different USB 2.0 hubs. Is there going to be a solution for this?
+1 vote
answered Dec 25, 2018 by marcgirard1 (160 points)
I have a Presonus FaderPort Classic that has been working fine in the last few years.

I wanted to update the software and mostly, the firmware.  I'm still at v1.0.

I tried everything.   Windows 10 x64 on USB3 and USB2 ports, I tried a Mac, I tried installed a brand new Windows 7 x64 on an old PC with USB2 ports.   I tried changing USB cables, long, shorts, etc.   I tried with and without the power supply connected (even though we know it is for the fader motor only).   I'm sorry Presonus but this is a fiasco.   Universal Control might look slick but it doesn't work at all on FaderPort Classic.   There's many users here complaining about this, please do something about it.
+1 vote
answered Dec 29, 2018 by deangallant (160 points)
Same issue for me (IOS). Tried a USB 2.0 Hub, and still no luck...

Finally dug out an old PC laptop, and that worked...

+1 vote
answered Jan 4, 2019 by timmorris (820 points)
Also can't update, FP1 works as a controller, when I push the fader it operates the mixer on screen, but no motor fader.

Using S1 Pro latest version, when updating I get to the 3 flashing buttons then just an error triangle, no code or message.

Pretty poor really.

Mac on latest OS.
+1 vote
answered Jan 6, 2019 by kadoikenji (160 points)
I also suffered from this error many times.
But when I tried using USB 2.0 mac book pro (2010), I could easily complete the update.
+1 vote
answered Jan 19, 2019 by jcrakes (270 points)
I am unable to use the Faderport motorized fader also... Getting the same error code as listed by posters above... Tried both USB3 and USB2 ports with no success...Somebody at Presonus must monitor the Questions and Answers page--- how about an official response besides the one from above???   I hope its not a case of "ignore it and it will go away"... Come on Presonus, at least pretend to address the issue, and if it has been worked on, let us know!
+1 vote
answered Feb 20, 2019 by ericdaugu (230 points)
Same problem here, is there anybody at PreSonus, not asleep at his desk, willing to take some time to answer a problem faced by apparently a lot of customers. Unless they couldn't care less about losing potential buyers of other products. If the support is that bad I will definitely stay away from PreSonus gear in the future.
+1 vote
answered Mar 9, 2019 by chriscline7 (160 points)
After spending hours trying to get a brand new Faderport Classic to work with my current Macintosh, i'm throwing in the towel.  As many people on here have stated, it's near impossible to make this happen on both the Mac and Windows platform.  I've looked at countless threads, have tried multiple Macs in my home (4 to be exact) and different USB 2 hubs to no avail.  As a professional engineer, one that currently uses Apogee, Burl, and UA, I had never thought of using PreSonus products at any level, especially converters.  Faderport, however, looked like a pretty great package for mixing on the go or if I had a smaller session with a low track count.  Trying to get this piece of kit to work has been such a letdown.  PreSonus... please try to find a better way to support your product, and more importantly, your customers.
0 votes
answered Apr 9, 2019 by AxeAshbrooke (430 points)
On Windows 10 here, and a macOS Mojave. Neither have USB 2.0 ports apparently. Can't update this to use the motorized fader. My old laptop is still running XP, which is not compatible with Universal Control.

PreSonus, this isn't cool. USB 3.0 should be backwards compatible with 2.0. Telling us we need to use 2.0 is B.S.
0 votes
answered Apr 23, 2019 by rainerkopa (200 points)
I've the same problem. I tried ist on a MacBook Pro 2018 - there are no USB 2 oder 3 - there are only USB-C/Thunderbolt 3 connections on it. No chance - not with a (2.0) Hub, not with anything else...

Please... PreSonus - give us a Hardwarelist of Hubs where an update is possible... USB-2.0 is not enough... Sorry...
0 votes
answered Jun 13, 2019 by woongjaeyoo (140 points)
edited Jun 13, 2019 by woongjaeyoo

Hey guys, I got my faderport classic updated today.

Here is my gig, it will be good if you guys get some help with this.

* even though your OS is window 10 64 bit,

if you have USB 2.0 ports on your motherboard, firmware update may go on, probably.

* gig:

PC: intel i7 8700 CPU and ASUS TUF H370-PRO gaming motherboard
OS: window 10, 64bit
Driver: Universal Control 3.0.1

Faderport setup:
SANWA USB2.0 cable [AM-BM] 1M [그레이/KU20-1HK]
NETmate 고주파 노이즈필터 [페라이트 코어] 6.5mm [NM-NF65] (ferrite core, bead)

USB interface(port):

NETmate U-710 (USB3.0카드/PCI-E/2port)

  -> I don't trust ASUS native USB 2.0 chipset, so my faderport classic and studio192 are connected to external PCIE USB 3.0 interface card.

and it was just bus powered on faderport classic.

+1 vote
answered Jul 30, 2019 by tapanisiirtola (1,460 points)
This has been reported over a year ago. The firmware upgrade is still not working. And yes, I'm using the native USB 2.0 port. Presonus, I'm disappointed.
0 votes
answered Aug 11, 2019 by stephentickner (180 points)
I just tried this on Mac OS High Sierra and Windows 10 using an old usb 2 hub and neither worked for me. I tried 2 different Macs. Its a pity Presonus wont support their customers by providing a firmware updater that works on modern computers...
0 votes
answered Sep 2, 2019 by joehamilton1 (140 points)
I was having the same issue and I use an old Mac mini without usb 3.0 and its updating
0 votes
answered Nov 23, 2019 by (290 points)
edited Nov 23, 2019 by

Hi all,

I did the update to v1.45 today with an old HP Elitebook 8540p Notebook running on Win10 x64. I used the newest UC Version which is available since Nov 19. Update took a few minutes but it worked well. Now I´m running my old Faderboard on v1.45.