Questions & Answers

Can not update Faderport firmware to 1.45 via latest UC.

+12 votes
asked Jul 11 in FaderPort Classic by (630 points)
I unplug USB connection : hold down REW,STOP and Record buttons : plug in USB and press OK on computer : get error code nr 0x8004005.

tried 2 diffrent mac with latest OS : same on both computers. cheers M

34 Answers

+3 votes
answered Jul 11 by gavinsteiner (880 points)
Just to let you know I'm facing the same issue. Windows 10 64bit.
0 votes
answered Jul 11 by Ninosachii (140 points)
do you have the faderport classic or the latest one.?? because i'm facing the same issue with my faderport classic
+2 votes
answered Jul 11 by (630 points)
Its Classic faderport and shows up in latesr UC device list.
+2 votes
answered Jul 12 by simonscholefield (220 points)

Yes I am getting the same error msg.  Have followed the instructions and tried everything I can think of or have read on forums etc but still get the 0x8004005 error msg.  The current firmware is reading as 1.0 and am attempting to update to 1.45.

Is the Faderport Classic on Windows 10 64bit

+1 vote
answered Jul 12 by fwubidzk (160 points)
I have the same problem on Windows10 x64.

So I 'm still usuing v1.0.
+3 votes
answered Jul 12 by emilteiger1 (340 points)
Same here with Faderport classic on osx (tried on several machines).
0 votes
answered Jul 12 by pierregauthier (420 points)
Same problem on my side.
+2 votes
answered Jul 12 by sithlrd73 (180 points)
Same here and now it wont work at all
+2 votes
answered Jul 12 by rainerpandolfi (190 points)

same error code here  .... Mac HighSierra with Faderport classic ... but not only not to upgrate the Firmware....  also the Faderport do not work anymore .... the old firmware is goen too

+1 vote
answered Jul 13 by tomtarai (250 points)
I have the same problem here on Windows10 x64. Presonus pls. fix this! Thanx
+1 vote
answered Jul 13 by (630 points)
selected Dec 4 by nickmaggio
Best answer

I got this answer from Presonus Tech Support :

" Technical SupportYesterday at 19:58

Hello Magnus,

Thank you for your continued patience as we work to assist you.

Please understand that the FaderPort classic cannot be updated on a USB 3.0 connection.

You will need to connect and update your FaderPort on a computer that has USB 2.0 connections.

You have some viable options.

- Find any other computer with USB 2.0 connection and update.


- Use a commonly available powered USB 2.0 hub.  Connect the FaderPort to this and update."

So I have to find some old USB 2 hub or Mac. I have tried to connect vis keyboard USB (2.0) but same error code.....

My Faderport Classic works fine with FW 1.0 so far....

/cheers M

0 votes
answered Jul 13 by (630 points)
So I connected via an old USB 2.o hub and voila : sucess : finally upgraded FW to 1.45. So try to use a USB 2.0 native usb or a USB 2.0 hub : that will probably do the trick .

/thanks for all answers and cheers M
0 votes
answered Jul 14 by michaelmockley (340 points)
Still not working, USB 2.0 right off the motherboard. unplugged everything except keyboard & mouse. running windows 10 (1803) unfortunately its still buggy.  v1.0 still works.
0 votes
answered Jul 14 by simonscholefield (220 points)
yeah I tried through usb 2.0 hub, still getting the same error msg.  Windows 10 64bit.  Will keep going with firmware 1.0.
+1 vote
answered Jul 16 by (630 points)
Okay so its seems to be a issue with the Faderport Classic firmware update in UC : as I posted before I had success on my Mac OS with an old external USB 2.0 hub : it did the trick for me. But there seems to be problems with Windows 64-bit .I hope Presonus adress this problem in next UC update.....

/cheers M
0 votes
answered Jul 16 by alexbyrd (140 points)
I also have the same problem  - win 10 64 bit  - even tried it on a virtual box running win 7 and forcing both the usb elements of  the faderport to only connect to the virtual machine. tried it on a usb2 hub as well as a usb 2 motherboard connection and it fails the same - still works under version 1 but would be nice to get it upto date.

hope we get an answer~

0 votes
answered Jul 16 by davechapman2 (140 points)
edited Jul 17 by davechapman2
Granted this is a legacy product, but to only make it updatable via a legacy port, really?

-- UPDATE --

Thank you, Magnus, I stand corrected. I'm am glad, however, that I save old tech hardware. Laugh if you must but I still have a 3.25 disk drive and my original DOS 6.1 install disks! (as well as Win3.1, 95, 98, NT Server) Maybe I need therapy!

Flash ran fine on an old Dell Vostro laptop.
+3 votes
answered Jul 17 by (630 points)
But its not a legacy product : Persons still sells them as "Faderport Classic" in their online shop....

so a firmware update should work on todays computer  .(eg USB 3 ).

/cheers M
+1 vote
answered Jul 18 by chiilthenkt1 (210 points)
Same problem! On Windows 10 x64, using USB2.0 port on motherboard already, anyone has solutions?
+1 vote
answered Jul 21 by HitzHits (620 points)
Is this a freaking joke? PreSonus.. hello????? USB 2... I don't have old stuff like that. Got ride of it years ago. I updated everything to UBS 3.0.

How in the world would you release an update that only works with legacy hardware...

So how can I update without USB 2.0 Hub? Why would I want to buy other stuff from you, if you can't even provide a driver for your hardware...

+1 vote
answered Jul 23 by robertnorberg (650 points)
Problem solved for me!

- Mac os Sierra.

I connected the Faderport "classic" to my Apple Keyboard usb 2.

// Robert
0 votes
answered Jul 24 by pierregauthier (420 points)
Done with an old laptop running Windows 7.
0 votes
answered Aug 4 by dmuckala (150 points)
Just to add to what's already been said on this thread...I was unable to update my faderport classic using any of the methods described: usb 2.0 hub attached to my macbook pro 2015 or trashcan didn't work.  Neither did apple classic keyboard usb 2.0.  I almost gave up until I remembered I had an old imac from 2009, so i got it out of the closet, fired it up, booted it off a usb drive that had El Capitan on it, and plugged the faderport into one of its native usb ports in the back which are obviously 2.0.  For some reason, that seemed to do the trick.  Pretty ridiculous that we have to jump through all these hoops to get a working faderport.
0 votes
answered Sep 3 by steveroche (140 points)
same issue.  Win 10, tried USB2.0 port as well.  still no fix for this?
0 votes
answered Sep 11 by pauldecesare (3,390 points)

I posted this same answer to a similar question about FaderPort 8... it's a weird answer but if you are stuck it's something to try: I had that same issue with my FaderPort 8 on the old firmware when it arrived last month, and also two years ago when I plugged in my Studio 192 Mobile with old firmware... in BOTH instances i was using the cheap supplied USB cable from PreSonus. The way I got the 192 to be recognized and connect was using a $40 digital USB cable, the ones that people say are snake oil. In almost 2 years my 192 has NEVER failed to spin right up now on this cable, and it's just on USB 2.0, not even 3.0 which isn't even necessary. Soooo, the FaderPort 8 shows up last month, and guess what... I could get it to connect in Windows 10, but it would hang when trying to actuallyt run it, and it wouldn't show up in UC. Frustrating. So I unplugged the digital cable from the 192 and tried that on the FaderPort 8, and I think you can guess what happened: FaderPort showed right up in UC, and the firmware update went off without a hitch. I now own 3 of these cables, one for the 192, one for FaderPort 8 and one for my M-Audio CODE61 (black) controller. Google how many people struggle with the CODE series keyboards... locking up, needing rebooting. I had the 49 then sold it for the 61, and neither keyboard has locked up, not ONCE, using the digital cables. I know... this is a weird answer, but the $120 I spent on three lousy USB cables has turned my home studio experience into a joy, at least hardware wise. Those cables don't do anything for consumer peripherals, but for a clean path for a ton of data in music production, they work. Funny thing is, the $40 version is the lower end! They make digital USB cables that cost about $80 and $120! The $40 one is perfecto for a digital music studio.

Nothing to lose, Amazon return policy is awesome.

0 votes
answered Sep 24 by alexshore (150 points)
Same issue, don't have any access to a USB 2.0 device either.
0 votes
answered Sep 26 by ukaszborowiecki (140 points)
I tray 5 diferent usb 2.0 hubs and 8 cables in all usb ports in my mac pro and finaly I get updata.. . ;)
0 votes
answered Sep 27 by tapanisiirtola (870 points)
Windows 10 64bit, Faderport classic plugged into USB 2.0 on a motherboard and I got the same error. This needs fixing!
0 votes
answered Oct 5 by brandonrubacha (140 points)
So, I just finished 3 months of trying to get this to work. I bought mine used from Guitar Center for $40 and it did not include a power supply. The fader would not work (motorized wouldn't work, it worked non motorized). I learned that you must have at least firmware V1.3 or above for the fader to work. So I tried to to update the firmware, same error code nr 0x8004005.

I tried multiple USB hubs, no luck. I tried a different windows 10 computer, no luck. (I ended up getting it updated) but even after getting it updated, fader still did not move automatically when I switched channels. (Also I was originally plugged into a USB 2.0 on my motherboard, so it's not just a USB 3.0 issue, but a driver issue with windows 10, thanks Presonus.)

To update the firmware I went to an old Window 7 laptop and the update worked.

After getting the firmware updated I couldn't get the fader working. Turns out the power supply I was using (I had to use one on hand because Guitar Center didn't send one) was the issue. The power supply fit and provided proper power, but for some reason it did not work. My multieffect board power supply ended up making it work.

Takeaway: Presonus fix the USB 3.0 issue and make it work on USB 3.0. Also fix the overall ability to update firmware on windows 10...
0 votes
answered Oct 30 by joegallo1 (140 points)
I'm having the same issue. I got mine through a trade but I am nervous to update the firmware now. I have an old iMac upstairs I can try to update on but once the Firmware is updated do I still have to be dependent on USB 2.0? Or is that only for the firmware update?
0 votes
answered Oct 30 by danielbuitron1 (150 points)

I've noticed that everyone seems to be saying doing it on a old (Windows 7 isn't very "old" if you ask me, I still use it) Win 7 machine worked. However I'm running said machine, 64-bit. And still doesn't work. I've tried plugging into the 2.0 ports on my tower, nothing has worked. I tried plugging it into the 2.0 hub built into my desktop monitor, still didn't work. Hell I even tried plugging it into a newer windows 10 laptop with only usb 3.0 ports and that still did not work. I don't know what the issue is here! I bought mine used, but looks like perfectly new condition off of ebay. There really shouldn't be a problem here. Similar problems i've had with my Audiobox 22VSL; as much as I like Presonus products, they've never been so "plug and play" for me in my experience, sadly. I hope someone has a real solution for this. 

0 votes
answered Oct 31 by (630 points)
So I guess I was lucky : after updated firmware with an old USB 2.0 hub : I have been using my Faderport Classic now for

some time : using my ordinary USB 3.0 ports on MacPro : no problems . So it seems to be the update process that is the problem

for both Mac an PC.

/cheers Magnus Malmberg
0 votes
answered Nov 21 by philangus (7,350 points)
Presonus support, you really need to sort this out as clearly there is an issue. I have tried on my PC and my laptop. My PC has USB2, it does not work. My laptop is USB3 only, so I connected an old USB2 hub and it doesn't work with that either. I also tried the hub on the PC. I am using Windows 10 64 bit as well. I get the pop up, I get the device ready for update etc, I click OK and then after about 5 seconds I get the error. I have spent two hours trying lots of different ports and methods. Nothing works.
0 votes
answered Nov 24 by chrislafargue (190 points)
Still not working . PreSounus a solution please!!!