Questions & Answers

Can not update Faderport firmware to 1.45 via latest UC.

+20 votes
5,844 views
asked Jul 11, 2018 in FaderPort Classic by info@magnusmalmberg.se (720 points)
I unplug USB connection : hold down REW,STOP and Record buttons : plug in USB and press OK on computer : get error code nr 0x8004005.

tried 2 diffrent mac with latest OS : same on both computers. cheers M

54 Answers

0 votes
answered Nov 23, 2019 by anhofer@msn.com (140 points)
edited Nov 23, 2019 by anhofer@msn.com

Hi all,

I did the update to v1.45 today with an old HP Elitebook 8540p Notebook running on Win10 x64. I used the newest UC Version which is available since Nov 19. Update took a few minutes but it worked well. Now I´m running my old Faderboard on v1.45.

cheers

Rudi

0 votes
answered Dec 7, 2019 by ianstewart1 (950 points)
Having the same issue here:

- FadePort Classic
- macOS 10.13.6
- Mid 2012 MBP w/ (2) native USB2.0 ports

I've tried multiple ports (both directly on the laptop and via a hub), and multiple cables. Still No luck.

Come on Presonus. A year and a half on from the initial post and loads of other people saying they're experiencing the same thing, and still no solution?
0 votes
answered Dec 15, 2019 by tapanisiirtola (1,270 points)
12 / 15 / 2019. I tried the firmware again with my wife's laptop (Win10) and using the USB 2.0 port. Same error. It is time to admit that there is something wrong with your updater software? It's not a USB 2.0 port problem. I think I'll throw the Fadeport "Classic" to trash soon if there is no fix.
0 votes
answered Dec 21, 2019 by ronaldmiller6 (140 points)

No Firmware update needed.  See here https://answers.presonus.com/42146/faderport-classic-not-working-with-logic-pro-x-10-4-5

This worked for me and it installed in Logic Pro X automagicaly.  I was about to pop a cork!  

...