Questions & Answers

M-Audio's Oxygen Pro DAW Integration

0 votes
1,747 views
asked Dec 1, 2020 in Studio One 5 by lukeyntema (210 points)
I just got M-Audio's Oxygen Pro 49 MIDI controller and love it. But, I can not get the DAW integration features to work and that was the biggest selling point to me.

It's a brand new keyboard but does anyone have one and had similar issues or resolved it?

12 Answers

0 votes
answered Dec 10, 2020 by davidwhite15 (480 points)
selected Dec 10, 2020 by lukeyntema
 
Best answer

I purchased the new M-Audio Oxygen Pro 61 keyboard controller and am now working on getting all the sync-ups to work.  First, you have to register the keyboard controller and enter code you are given.  Download any software regarding this.

Next, go to:  https://m-audio.com/kb/article/1935, on the M-Audio website.  This has some information that helps get some things connected and working.  Of course, before attempting any connection, you must hook up the keyboard using the USB cord and also a midi connection cable, if connecting through an interface.

Use the keyboard's DAW Select button, holding it down a moment, and the turn the "Push to Enter" knob (just down and to the right of the DAW Select button) until the lit window screen displays "Studio One".  Then, push the "Push to Enter" button.  This does connect your keyboard to the Studio One software and you should see your keyboard listed when you go to add a "New Keyboard".

THIS IS KEY TO THE FEATURES FROM THE CONTROLLER CONNECTING TO THE DAW, FOR USE:

Code Keyboard Setup

First, we want to assign your Code transport to send as Mackie. This is basically a control language that will allow us to set up the controls of the keyboard without any mapping files or individually learning the functions. Here's how:

  1. Hit the EDIT button on your Code, located directly below the display
  2. Hold down the SHIFT button and hit the C# key labeled "MACKIE/HUI" until the display reads "Mackie"
  3. Release the SHIFT button

Your transport should now be sending as Mackie.

To allow some flexibility, the knobs, faders, and assignable buttons can send as MIDI CC, Mackie/HUI, or HID, but for our purposes with Studio One, we want to set these to send as Mackie/HUI. Each bank of parameters will have a "Mode" button that will change colors based on the mode the parameters are set to. Simply, hit each mode button until it lights up green. The screen should read "MACHUI" to confirm." (from the M-Audio website information)

If you have already selected the "DAW", as described above, on the keyboard controller, then when you open Studio One, or close it and reopen it, Studio One will recognize "Oxygen Pro 61" - although it will not be listed in the suggested items list.  Then, after reading the M-Audio info - I created "New Keyboard" for each of these, which I found in "Add ...", and then "New Keyboard", and the open the "M-Audio" choice:

1) Mackie Control, 2) Mackie Control Extender or Controle Extender, 3) HUI or Mackie HUI

The system gives directions for the Mackie Control, telling you to select "MIDIIN3" for Input and Output, so I used the "MIDIIN 2" and "MIDIIN 4" for the other two.

I have the keyboard controller connected to the DAW, and also have the first 5 sliders working as Volume faders for 5 separate tracks in my song, in correct order, and also the "Stop", "Go", and "Record" buttons work.  I haven't checked the rest, yet.  Working my way through!

+1 vote
answered Dec 4, 2020 by jlmcmurtry (160 points)
Same dude...

I have no idea how to get it to work. It’s a mess and makes no sense.

I’ve looked everywhere and can’t find any support.

The m-audio website has NO info or user manual uploaded.

Super disappointed and frustrated.

It’s nice tho...
0 votes
answered Dec 4, 2020 by lukeyntema (210 points)

I've talked to Presonus and they said "We aren't sure how to get it working one way or another. It isn't one of our listed keyboards in Studio One". 

M-Audio told me "It's too new we don't have any info on the issue.

???

I'm glad to know there is at least one other person with the keyboard and studio one indecision not just me. But I've emailed M-Audio again trying to get support and still researching the issue so if I figure it out I will post here. Might just return it though, not having transport buttons at all is definitely a deal breaker for my situation...

0 votes
answered Dec 9, 2020 by sattaway88 (160 points)
Same issue and I'm looking all over for answers and I can't find any, I'm about to just custom map everything, I love this thing but we need answers!
0 votes
answered Dec 11, 2020 by kevinturbitt (340 points)
Same here. I've selected Studio One on the keyboard (using the DAW select function). That didn't do it. I've tried adding the Oxygen as a both a keyboard and controller. Tried MIDI learn. No luck.

I've also tried using another DAW (Bitwig) without success.

Hoping a solution will be found soon. (The answer from davidwhite15 refers to the Code Keyboard, which is a different keyboard, so that doesn't work).
+1 vote
answered Dec 21, 2020 by kevinturbitt (340 points)

M-Audio has finally posted instructions and I've got it to work! Here's the link:

https://inmusicbrands.force.com/maudio/s/article/M-Audio-Oxygen-Pro-Series-Setup-in-Studio-One

+4 votes
answered Jan 8 by brunofernandez-ruiz (250 points)
The Studio One setup guide for the Oxygen Pro at M-Audio seems to get both the keyboard and the Mackie/HUI control working.

However, I am seeing that regardless of what track I select, the first track for the bank is always armed for recording and monitoring. It does not matter that I try to unselect it directly in Studio One, it just stays on. I have watched videos of users on Logic Pro and Ableton who do not seem to have this problem, so I am thinking it might be a setting in the DAW control configuration in the Oxygen Pro. Has anybody figured out how to avoid the first track being always armed?

There is also a custom DAW mode which can be edited ... but there is zero documentation and M-Audio support is, well, non existent for all practical purposes.
+2 votes
answered Jan 19 by kevinturbitt (340 points)
I'm having the same issue where track one is always armed. I have to create an empty track and set its input to none if I want to use the features I bought this keyboard for. Very frustrating, and zero response from M-Audio.
+1 vote
answered Feb 2 by petermoran1 (160 points)
Hi all.

Regarding the first track always being armed, I think I have a work around. Using the Oxygen Pro editor (available if you select show advanced in the M-Audio Download Manager software), I was able to set every fader and knob in all banks to communicate using HUI instead of Mackie Control.

Then, in Studio One 5 when adding the controller, instead of selecting the Mackie Control as the device, I selected Mackie HUI. This has all the faders, knobs, and mute/solo buttons working for me but the first track isn't always armed.

No idea if there is a drawback to using HUI and it's a pain to initially change all the outputs in the editor (across all 4 banks!!!) but it's working for me.

Hope this helps.
0 votes
answered Feb 10 by kevinturbitt (340 points)

Thanks petermoran1. The one downside to this is (at least for me) there is no Master volume control with the keyboard using HUI vs Mackie Control. I think the hardware HUI didn't have this feature, so it make sense, but it means that Slider 9 loses is function as a volume control. That may be the lesser of two evils depending on your needs.

0 votes
answered Feb 24 by jaredmoore4 (140 points)
At present the M-Audio "knowledge base" link (https://inmusicbrands.force.com/maudio/s/article/M-Audio-Oxygen-Pro-Series-Setup-in-Studio-One) for this setup procedure is broken, and just loads an indexing page of some type with no useful info. Does anyone have a general walkthrough of this setup process? I am currently not having any luck with it, and some of the other answers are a little esoteric without having access to the original M-Audio guide I am afraid.
0 votes
answered Mar 3 by darrenshady (180 points)

The question answered by davidwhite15 I couldn't really follow, but not makes sense after working with support  I got on the phone with support who was confused by needing MACKIU control.  

I captured MIDI data on one channel selection, it was arming record on Channel 1. There is no way to unarm.  

MIDIIN3 is sending NoteOn C -2 127.

Selecting NONE (or any other MIDI IN) on the Mackie Control appears to have resolved it.Changing Channels Arms records via MIDIIN3

Setting the Mackie Control Send to = None

M-Audio support has been worthless.  I cannot get them on the phone, or to reply via email.

...