Questions & Answers

universal control can't connect to Studiolive 32SC

+3 votes
2,766 views
asked Dec 10, 2022 in StudioLive Series III by marccollet (150 points)
just installed Universal Control to set up and update my newly bought studiolive 32 SC but it seems,it can not be connected.

i see the icon of the <studiolive but in the upper right corner in the Studio Live line a circle keeps on spinning.

I am on windows 10 and used different USB ports but no result.

who can help me out

Marc

7 Answers

0 votes
answered Feb 4, 2023 by brendonchan (340 points)
Hi, I have the same problem now. Were you able to resolve it?
+1 vote
answered Mar 24, 2023 by colinlaird (160 points)
I can get it to connect over the ethernet cable.  But I must unplug the USB.

StudioOne will connect through the USB, but Universal Control just spins.  If I pull the USB cable, it'll connect as well.
0 votes
answered Jun 19, 2023 by billlong (340 points)
Yes, unplugging the USB connection to the StudioLive 32SC and replugging it in seems to (eventually) resolve the annoying disconnect problem.
0 votes
answered Oct 1, 2023 by jeffburgener (280 points)
Same problem here.  Unplugging then pluging in the USB cable does nothing. Still stuck.
0 votes
answered Oct 25, 2023 by stevedaymusic (810 points)
The issue is still happening and feels like an inherent hardware malfunction with the 32SC, since we all have the same issue.

My firmware is updated to the latest version and it still happens.  It happened before the firmware update as well.

Imagine spending $2,000 on a product that you literally cannot trust to use in a live environment because of how unstable it is.
0 votes
answered Nov 11, 2023 by desmondoreilly (290 points)
was anyone able to find a fix to this issue?
...